Ruby 1.8.7 fine ciclo vita: e Archimista?

Da Ruby 1.8 a Ruby 2.0

Messaggioda Bernardino » 04/07/2013, 9:42

Mi sembra elementare la scelta di aggiornare Ruby alla versione 2.0.
D'altronde, in mezzo c'è già stata la versione 1.9.x e da tempo si sollecita la comunità che usa Ruby a passare alla versione 2.0.
Anche il framework di Rails http://rubyonrails.org/core che è alla versione 4.0 non sostiene più la versione di Ruby 1.8 e chiede di passare alla versione di Ruby 2.0.
In sostanza anche Archimista dovrebbe al più presto adottare la versione di Ruby 2.0.

Per chi volesse sperimentare una proceduta automatizzata di installazione di Ruby e dei suoi componenti, sia per Windows che per Mac, può usare questo servizio, anche se installa la versione di Ruby 1.9.3:
http://railsinstaller.org/

Oppure si può utilizzare la risorsa di RailsInstaller per Windows che installa Ruby 2.0 in versione beta:
http://rubyforge.org/frs/?group_id=5288 ... e_id=47210
Bernardino
Socio ANAI
 
Messaggi: 152
Iscritto il: 25/02/2009, 16:22
Località: Bergamo

Ruby 1.8.7 fine ciclo vita: e Archimista?

Messaggioda svassallo » 03/07/2013, 9:22

http://www.ruby-lang.org/en/news/2013/0 ... ire-1-8-7/

Ossia il ramo (la versione 1.8.x) di uno dei componenti (sostanzialmente l'interprete del linguaggio di programmazione usato) da fine giugno non sarà più aggiornato nemmeno in caso di gravi problemi di sicurezza. Solo le versioni 1.9 e la 2 d'ora in poi avranno aggiornamenti.

Per dirla alla Dante: Archimista, qui si parrà la tua nobilitate, per capire se non sei semplicemente un nuovo Sesamo :)

Ovviamente si possono lasciare le cose come stanno (vecchio adagio degli informatici if it ain't broke don't fix it, se non è rotto non aggiustarlo https://en.wiktionary.org/wiki/if_it_ai ... 27t_fix_it). Altrettanto ovviamente sconsiglierei l'installazione almeno della versione server (su quella standalone dipende dal baco) al primo sorgere di bachi critici che, per quando detto sopra, non saranno mai più corretti in questa versione di Ruby.

Non voglio fare allarmismi: la situazione almeno allo stato attuale non è problematica visto che da quando è nato Ruby 1.8 sono stati riportati 20 problemi di sicurezza (relativamente pochi) e sono stati tutti corretti. Per questi dati e per monitorare eventuali criticità future si veda http://secunia.com/advisories/product/3 ... advisories
È così che muore la libertà, sotto scroscianti applausi. (Star Wars – La vendetta dei Sith)
svassallo
Socio ANAI
 
Messaggi: 345
Iscritto il: 19/03/2009, 11:08


Torna a Altri suggerimenti e segnalazioni

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron